The Flaming Lips

Want to join the discussion? log in (or register, if you don't have an account)

Problems with Gummy Fetus USB


I just received a gummy fetus in the mail the other day. I took it out of the shrink wrap and located the USB stick and cut it out of the candy. When I plugged it into my computer I was prompted by the computer that I would have to format the USB before I can use it. This of course would delete all the files. I was then prompted that the USB does not contain a recognizable file system. I'm pretty frustrated at this point so I took the USB and plugged it into my Blu ray player and it worked fine, so I know the files are on there. Does anyone know what might be causing this problem? I was told that because my computer is windows based, if the USB was formatted on a Mac that might be the problem. I tried contacting the site but haven't yet received a reply. Please help! This is very frustrating.

Mar 8, 2012 - 8:26am

I had the same problem. I did get a response from the people who run the site with a link to download the songs. Not sure whats the issue with the usb however.

Mar 19, 2012 - 6:01pm

I had the same issue. But I ate out my USB (it took a few days)-- see pic. I contacted the people who run this site for help a few minutes ago.

[url=]The Independent Ethos - Handmade with vinyl and celluloid[/url] Mar 26, 2012 - 12:14pm
log in to post
don't have an account? make one here


upcoming tour dates